男科病去什么医院:唐能通选股公式修正(2008-12-28 18:22:00)

来源:百度文库 编辑:欧普网 时间:2019/09/21 13:42:22
唐能通选股公式修正(2008-12-28 18:22:00)转载 标签:

杂谈

唐能通选股公式修正 主图——短线是银
MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);
MA20:MA(CLOSE,20);
MA40:MA(CLOSE,40);
ma60:ma(c,60);
TY:=C;
A1:=REF(TY,10)=HHV(TY,2*10 1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10 1); HD:=FILTER(C1,10);
A2:=REF(TY,10)=LLV(TY,2*10 1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10 1); LD:=FILTER(C2,10);
前期高位:REF(H,BARSLAST(HD)),COLOR00FF00,POINTDOT;
前期低位:REF(L,BARSLAST(LD)),COLORFF00FF,POINTDOT;
STICKLINE(C,前期高位,前期高位,5,0),Color00FF00;
STICKLINE(C,前期低位,前期低位,5,0),ColorFF00FF;
月价托:=ma5>ma20 and ma5>ma10 and cross(ma10,ma20);
季价托:=ma20>ma60 and ma20>ma40 and cross(ma40,ma60);
短长价托:=ma5>ma60 and ma5>ma10 and cross(ma10,ma60);
drawtext(月价托,l-0.12,'月价托'),coloryellow;
stickline(月价托,h,l,0.5,1),coloryellow;
stickline(月价托,o,c,6,1),linethick2,coloryellow;
drawtext(季价托,l-0.12,'季价托'),color0099ff;
stickline(季价托,h,l,0.5,1),color0099ff;
stickline(季价托,o,c,6,1),linethick2,color0099ff;
drawtext(短长价托,l-0.12,'短长价托'),color36c0c1;
stickline(短长价托,h,l,0.5,1),color36c0c1;
stickline(短长价托,o,c,6,1),linethick2,color36c0c1;
vol5:=MA(VOL,5),colorwhite;
vol10:=MA(VOL,10),coloryellow;
vol20:=MA(VOL,20),colorff00ff ;
量托:=vol5>=vol20 and cross(vol10,vol20) and ref(vol10,1)<ref(vol20,1);
drawtext(量托,l*0.97,'量托'),colorwhite;
stickline(量托,h,l,0.5,1),colorwhite;
stickline(量托,o,c,6,1),linethick2,colorwhite;
aa:=BARSLAST(ma60>ma40 and (ma40=ma20 or ma40>ma20));
bb:=ref(count(c<ma60,aa)=aa,1);
cc:=cross(c,ma60) and vol>ma(vol,5) and (c-ref(c,1))/ref(c,1)*100>3;
芙蓉出水:=bb and cc,color00ff00;
drawtext(芙蓉出水,l-0.12,'芙蓉出水'),colorff00ff;
stickline(芙蓉出水,h,l,0.5,1),colorff00ff;
stickline(芙蓉出水,o,c,6,1),linethick2,colorff00ff;
滚滚红尘 17:09:08
刚才我设了不接任何信息
股道迷航 17:09:08
(2008-08-26 17:04:59)   股道迷航(492132561)
<短线是银>10合1指标


{参数;N:5,30,8;ZF:1,10,5;m:1.100.3;n10:1.100.9;p1:1.100.3;p2:1.100.3}
MA5 := MA(close,5);
MA10 := MA(close,10);
MA60 := MA(close,60);
pday1 := barslast(cross(ma60,ma5));{5日均线下穿60日均线}
pday2 := barslast(cross(ma60,ma10));{10日均线下穿60日均线,至此形成鸭颈部}
pday3 := barslast(low=llv(low,pday2));{形成头部,要反弹}
pday4 := barslast(cross(ma5,ma10));{反弹后,5日均线和10日均线金叉}
pday5 := barslast(cross(ma10,ma5));{反弹不久,5日均线和10日均线形成死叉,形成嘴部}
a1:= pday1>pday2 and pday2>pday3 and pday3>pday4 and pday4>pday5 and pday5<5;
a2:= count(cross(ma10,ma5),pday2)=1;
唐鸭头:A1 AND A2,COLORffff00;
DRAWTEXT(唐鸭头,0.8 , '唐鸭头'),COLORred;
Var1:=MA(CLOSE,5);
Var2:=MA(CLOSE,10);
Var3:=MA(CLOSE,60);
Var4:=BARSLAST(CROSS(Var1,Var3));
Var5:=BARSLAST(CROSS(Var2,Var3));
Var6:=BARSLAST(HIGH=HHV(HIGH,Var5));
Var7:=BARSLAST(CROSS(Var2,Var1));
Var8:=BARSLAST(CROSS(Var1,Var2));
Var9:=Var4>Var5 AND Var5>Var6 AND Var6>Var7 AND Var7>Var8 AND Var8<5;
VarA:=COUNT(CROSS(Var2,Var1),Var5)=1;
老鸭头:Var9 AND VarA and Var3>ref(Var3,1),COLORFF00FF;
DRAWTEXT(老鸭头 ,0.8 , '老鸭头'),COLORred;
nA1:=MIN(MA(C,5),MA(C,10))>MA(C,60) AND CROSS(MA(C,5),MA(C,10));
nA2:=MIN(MA(C,5),MA(C,10))/MA(C,60)<1.05;
nA3:=COUNT(V6;
青龙取水:nA1 AND nA2 AND nA3,COLOR00FF00,LINETHICK2;
DRAWTEXT(青龙取水 ,0.8 , '青龙取水'),COLORred;
线:=ma(c,180)>ref(ma(c,180),2) and count(cross(ma(c,5),ma(c,180)),6)>=1 and c/ma(c,180)
>1.04,COLORblue;
穿180线:ma(c,180)>ref(ma(c,180),2) and count(cross(ma(c,5),ma(c,180)),6)>=1 and c/ma(c,180)
>1.04,COLORblue;
DRAWTEXT(穿180线,0.8 , '180'),COLORblue;
VAR32:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR33:=SMA(SMA(VAR32,3,1),3,1)/28.57;
VAR34:=EMA(VAR33,5);
VAR35:=3*VAR33-2*VAR34;
绝买:CROSS(VAR35,VAR33) AND VAR33<2.1 and c>o,COLORred;
DRAWTEXT(绝买,0.9,'绝买'),COLORred;
ss1:=(LOW+HIGH+CLOSE*2)/4;
ss2:= MA(ss1,4);
ss3:=HHV(ss2,10);
ss4:=ma(ss3,3);
ss5:=1.25*ss4-0.25*ss3;
xkkj:=if(ss5>ss3,ss3,ss5);
ff1:=LLV(ss2,10);
ff2:=ma(ff1,3);
ff3:=1.25*ff2-0.25*ff1;
dkkj:=if(ff3ma13:=ma(c,13);
zdhm:=cross(c,dkkj) and cross(c,ma13) and cross(c,xkkj);
zhm:=cross(c,ma13) and cross(c,xkkj);
的卢:zdhm or zhm,COLORgreen;
DRAWTEXT(的卢,0.5,'的卢'),COLORred;
MA111:=MA(CLOSE,20);
MA112:=MA(CLOSE,40);
MA113:=MA(CLOSE,60);
A11:=OPENA12:=C>MAX(MA111,MAX(MA112,MA113)),COLORred;
A13:=V/MA(V,30)>1.2,COLORred;
A14:=C/REF(C,1)>1.049,COLORred;
芙蓉:A11 AND A12 AND A13 AND A14,COLORwhite;
DRAWTEXT(芙蓉,0.3,'出水芙蓉'),COLORwhite;
J:=(C*2+H+L)/4;
K:=(EMA(J,13) - EMA(J,21))*180;
D:=EMA(K,2);
kk:=(K-D);
dd:=-1*(K-D);
ss:=CROSS(kk,dd);
VARbb:=EMA(EMA(CLOSE,5),5);
ll:=(VARbb-REF(VARbb,1))/REF(VARbb,1)*1000;
mm:=CROSS(ll,0);
黄买蓝出:ss and mm,COLORyellow;
DRAWTEXT(黄买蓝出,0.5,'黄买蓝出'),COLORred;
RSV100:=(CLOSE-LLV(LOW,N10))/(HHV(HIGH,N10)-LLV(LOW,N10))*100;
K10:=SMA(RSV100,P1,1);
D10:=SMA(K10,P2,1);
J10:=3*K10-2*D10;
kdj买点:j10<0,COLOR0066ff;
DRAWTEXT(kdj买点,0.2,'kdj买点'),COLOR0066ff;
Var201:=CLOSE-REF(CLOSE,1);
Var202:=IF(CLOSE-REF(CLOSE,1)>=0,Var201,0);
Var203:=REF(CLOSE,1)-CLOSE;
Var204:=IF(CLOSE-REF(CLOSE,1)<=0,Var203,0);
Var205:=SUM(Var202,8)/SUM(Var204,8);
Var206:=1-1/(1+Var205);
短线: EMA(Var206,3),COLORyellow;
Var207:=LLV(LOW,50);
Var208:=HHV(HIGH,50);
Var209:=EMA(CLOSE,2);
中线: EMA((Var209-Var207)/(Var208-Var207),8),COLOR00FF00;


股道迷航 17:09:18
(2008-08-26 17:05:36)   股道迷航(492132561)
多方炮
Var1:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)OPEN;
Var1;

DIF上穿零线
Var1:=EMA(CLOSE,12)-EMA(CLOSE,26);
COUNT(Var1>=0,60)=1 AND Var1>=0;


DIF下穿零线
Var1:=EMA(CLOSE,12)-EMA(CLOSE,26);
COUNT(Var1<=0,60)=1 AND Var1<=0;

放量过头
Var1:=HHV(HIGH,60);
Var2:=CLOSE>Var1;
Var3:=VOL>MA(VOL,5)*2.5 OR COUNT(VOL>MA(VOL,10),6)>4;
Var2 AND Var3;


黑马草上飞
Var1:=(CLOSE-MA(CLOSE,60))/MA(CLOSE,60)*100;
Var2:=COUNT(MA(CLOSE,60)>REF(MA(CLOSE,60),1),100)>95;
Var3:=COUNT(Var1<20,100)>95;
Var4:=COUNT(CLOSE>MA(CLOSE,60),100)>80;
Var5:=CLOSE/REF(CLOSE,1)>1.04;
Var6:=VOL/CAPITAL*100>2.8;
Var7:=Var2 AND Var3 AND Var4 AND Var5 AND Var6;
Var7 AND (REF(BARSLAST(Var7),1)>20 OR BARSSINCE(Var7)=0);

空方炮
REF(CLOSE,2)REF(OPEN,1) AND CLOSED!LBCJ
Var1:=MA(CLOSE,60);
Var2:=COUNT(CLOSE31;
Var3:=CROSS(CLOSE,Var1);
Var4:=CLOSE/REF(CLOSE,1)>1.045;
Var2 AND Var3 AND Var4;


老鸭头
Var1:=MA(CLOSE,5);
Var2:=MA(CLOSE,10);
Var3:=MA(CLOSE,60);
Var4:=BARSLAST(CROSS(Var1,Var3));
Var5:=BARSLAST(CROSS(Var2,Var3));
Var6:=BARSLAST(HIGH=HHV(HIGH,Var5));
Var7:=BARSLAST(CROSS(Var2,Var1));
Var8:=BARSLAST(CROSS(Var1,Var2));
Var9:=Var4>Var5 AND Var5>Var6 AND Var6>Var7 AND Var7>Var8 AND Var8<5;
VarA:=COUNT(CROSS(Var2,Var1),Var5)=1;
Var9 AND VarA;


量芝麻点
Var1:=MA(VOL,40);
Var2:=VOL/CAPITAL*100;
Var3:=COUNT(VOLar1<1.3,14)>11;
Var4:=CROSS(Var2,2);
Var5:=CLOSE/REF(CLOSE,1)>1.025 AND CLOSE>OPEN;
Var6:=Var3 AND Var4 AND Var5;
Var6;


青龙取水
Var1:=MIN(MA(CLOSE,5),MA(CLOSE,10))>MA(CLOSE,60) AND CROSS(MA(CLOSE,5),MA(CLOSE,10));
Var2:=MIN(MA(CLOSE,5),MA(CLOSE,10))/MA(CLOSE,60)<1.05;
Var3:=COUNT(VOL6;
Var1 AND Var2 AND Var3;

三死叉见顶
Var1:=5;
Var2:=HHV(HIGH,20)/HIGH<=1.15;
Var3:=MA(CLOSE,5);
Var4:=MA(CLOSE,10);
Var5:=MA(VOL,5);
Var6:=MA(VOL,10);
Var7:=EMA(CLOSE,12)-EMA(CLOSE,26);
Var8:=EMA(Var7,9);
Var9:=BARSLAST(CROSS(Var4,Var3));
VarA:=BARSLAST(CROSS(Var6,Var5));
VarB:=BARSLAST(CROSS(Var8,Var7));
VarC:=IF(Var9<=Var1 AND VarA<=Var1 AND VarB<=Var1,1,0);
VarC;

天上井地下井
Var1:=MA(CLOSE,5);
Var2:=MA(CLOSE,10);
Var3:=MA(CLOSE,20);
Var4:=MA(CLOSE,30);
Var5:=COUNT(CROSS(Var3,Var1),21)=1 AND COUNT(CROSS(Var4,Var1),21)>0 AND COUNT(CROSS
(Var3,Var2),21)>0 AND COUNT(CROSS(Var4,Var2),21)>0;
Var6:=MA(VOL,5);
Var7:=MA(VOL,10);
Var8:=MA(VOL,20);
Var9:=MA(VOL,30);
VarA:=COUNT(CROSS(Var8,Var6),21)=1 AND COUNT(CROSS(Var9,Var6),21)>0 AND COUNT(CROSS
(Var8,Var7),21)>0 AND COUNT(CROSS(Var9,Var7),21)>0;
VarB:=COUNT(Var5,13)>0 AND COUNT(VarA,13)>0;
VarB AND (REF(BARSLAST(VarB),1)>20 OR BARSSINCE(VarB)=0);

量托
n1=5,n2=10,n3=20
Var1:=MA(VOL,N1);
Var2:=MA(VOL,N2);
Var3:=MA(VOL,N3);
Var4:=COUNT(CROSS(Var1,Var2),21)=1 AND CROSS(Var2,Var3) AND COUNT(CROSS(Var1,Var3),21)=1 AND
BARSLAST(CROSS(Var1,Var2))>BARSLAST(CROSS(Var1,Var3)) AND BARSLAST(CROSS(Var1,Var3))>BARSLAST
(CROSS(Var2,Var3)) AND Var1>REF(Var1,1);
Var4;

量压
n1=5,n2=10,n3=20
Var1:=MA(VOL,N1);
Var2:=MA(VOL,N2);
Var3:=MA(VOL,N3);
Var4:=COUNT(CROSS(Var2,Var1),21)=1 AND CROSS(Var3,Var2) AND COUNT(CROSS(Var3,Var1),21)=1 AND
BARSLAST(CROSS(Var2,Var1))>BARSLAST(CROSS(Var3,Var1)) AND BARSLAST(CROSS(Var3,Var1))>BARSLAST
(CROSS(Var3,Var2)) AND Var1Var4;

一阳上穿三角托
n1=20,n2=40,n3=60
Var1:=MA(CLOSE,N1);
Var2:=MA(CLOSE,N2);
Var3:=MA(CLOSE,N3);
Var4:=COUNT(CROSS(Var1,Var2),21)=1 AND CROSS(Var2,Var3) AND COUNT(CROSS(Var1,Var3),21)=1 AND
BARSLAST(CROSS(Var1,Var2))>BARSLAST(CROSS(Var1,Var3)) AND BARSLAST(CROSS(Var1,Var3))>BARSLAST
(CROSS(Var2,Var3)) AND Var1>REF(Var1,1);
Var5:=CLOSE>MAX(Var1,MAX(Var2,Var3)) AND OPENVar6:=COUNT(Var5,21)=1;
Var4 AND Var6;

短线是银之价托
m1=20,m2=40,m3=60,NDAY=1
Var1:=MA(CLOSE,M1);
Var2:=MA(CLOSE,M2);
Var3:=MA(CLOSE,M3);
Var4:=BARSLAST(CROSS(Var1,Var2));
Var5:=BARSLAST(CROSS(Var1,Var3));
Var6:=BARSLAST(CROSS(Var2,Var3));
Var7:=IF(Var4>Var5 AND Var5>Var6 AND Var6<=NDAY,1,0);
Var8:=IF(Var1>Var2 AND Var2>Var3 AND CLOSE>Var1,1,0);
Var7 AND Var8;

短线是银之量托
m1=20,m2=40,m3=60,NDAY=1
Var1:=MA(VOL,M1);
Var2:=MA(VOL,M2);
Var3:=MA(VOL,M3);
Var4:=BARSLAST(CROSS(Var1,Var2));
Var5:=BARSLAST(CROSS(Var1,Var3));
Var6:=BARSLAST(CROSS(Var2,Var3));
Var7:=IF(Var4>Var5 AND Var5>Var6 AND Var6<=NDAY,1,0);
Var8:=IF(Var1>Var2 AND Var2>Var3 AND VOL>Var1,1,0);
Var7 AND Var8;

短线是银之绝对量顶天
n=125
IF(HHV(VOL,N)=VOL,1,0);
交叉
5日线上穿10日线且本次交叉距上次交叉50天以上
Var1:=MA(CLOSE,5);
Var2:=MA(CLOSE,10);
Var3:=BARSLAST(CROSS(Var1,Var2));
Var4:=REF(Var3,1);
IF(Var4>=50 AND Var3=0,1,0);


条件选股公式——短线是银之三金叉见底
nday := 5;
down := closev(low,60)<=1.2;
pma1 := ma(close,5);
pma2 := ma(close,10);
vma1 := ma(vol,5);
vma2 := ma(vol,10);
diff := ema(close,12) - ema(close,26);
dea := ema(diff,9);
ppday := barslast(cross(pma1,pma2));
vvday := barslast(cross(vma1,vma2));
macdday := barslast(cross(diff,dea));
sjcjd:= if((ppday<=nday and vvday<=nday and macdday<=nday),1,0);