男科那家医院好:ROS限速

来源:百度文库 编辑:欧普网 时间:2019/09/20 18:43:14
作者:未知 点击数: 3662 更新:2009-4-10 21:35:35   热     ★★★ 收藏到QQ书签
首先说说我为什么要做这个限速,一般来说,PCQ限速对于某些带宽不是很足的网吧来说,确实有点问题,必须你网吧只有15M的光纤,如果你做PCQ限速2M吧(我想2M对于100台机器来说的网吧已经是最大限度了),PCQ开启设置为14M吧,关闭设置为6M!如果有一个人用讯雷下载东西的话。网吧15马上占满,PCQ就会开启,但一旦开启后。你网速就会变到6M以下,那么PCQ就在那里不停的关闭和开启了,这样不单达不到智能限速的效果。还会增加ROS的负担!CPU占用。。所以我就一直想把智能和普通限速做在一起,让讯雷或者其他下载不会乱触发PCQ的流量,但最终还是失败了!
不过得到网盟热心朋友 ( 我叫阿当 ) 的启发,我想出了一个既可以动态限速,也可以静态限速的方法!例如,还是15M的光纤,100台机器的网吧。我静态设置为3M,这样的话,正常来说。4个人下载东西的话,也只占12M,那么还剩3M,足够其他玩Q和打网游的机器了!
但如果5个人下载的话?怎么办?带宽马上到了15M了。呵呵,那其他玩网游的肯定会卡死!
不用怕,我智能设置为大于14M触发另一个脚本,脚本的内容大概就是关闭原来的3M静态限速,开启1.5M的静态限速,这样一算,1.5*5=7.5M了,再加上玩网游的人,基本上就稳定在10M左右了!
然后再设置一个脚本,当总流量少于6M的话(也就算没那么多人下载了,流量下来了)那么1.5M的静态限速脚本就会自动关闭,又打开了本来3M的限速了!
基本上原理就是这样。通过这个原理,网吧宽带利用就会越来越合理!
不过。这个方法还是有一定的局限的,如果你还是用433的CPU,建议还是算了吧。呵呵,因为在2秒内完成脚本转换需要开启254条限速和开始254条限速,所以对于ROS的配置还是要讲究一点的。我的测试是在C1.8 256M内存的状态下测试的。脚本自动切换的时候ROS的CPU占用会突然升到100,但是并不影响网络,虽然在ROS上看是断流了一两秒,但实际上,我ping着163的IP并没有延时突然升高,玩网游的人也不会卡一两秒!可以说是完美切换了!
=====================================================
 
下面是 我叫阿当 的网友发出来的智能限速脚本,通过这个脚本,如果有心看我的文章的人应该可以写出我的智能脚本了!
动态限速
ROS动态限速(检测外网总速度进行限速开关)废话不说先看脚本原理:
以下操作全部在WINBOX界面里完成
介绍:可以实现在总速度不超过9M的情况下自动关闭所有生成的限速规则在总速度超过18M的时候自动启动所有生成的限速规则。
说明:在输入脚本内容时不要把两边的()带上,那个是为了区分非脚本字符。
总速度=你的外网网卡当前速度。
打开 /system/scripts
脚本:
:for aaa from 1 to 254 do={/queue simple add name=(ip_ . $aaa) dst-address=(192.168.0. . $aaa) interface=wan max-limit=256000/800000 burst-limit=1000000/3000000 burst-threshold=128000/512000 burst-time=30s/1m     }
上面是生成限速树,对网段内所有IP的限速列表!
下面进入正题:
脚本名:node_on
脚本内容:(:for aaa from 1 to 254 do={/queue sim en [find name=(ip_ . $aaa)]})
脚本名:node_off
脚本内容:(:for aaa from 1 to 254 do={/queue sim dis [find name=(ip_ . $aaa)]})
scripts(脚本部分)以完成
打开 /tools/traffic monitor
新建:
名:node_18M     traffic=received     trigger=above     on event=node_on threshold:18000000
新建:
名:node_9M     traffic=received     trigger=below     on event=node_off     threshold:9000000
在输入脚本内容时不要把两边的()带上,那个是为了区分非脚本字符。
==============================================================
:for aaa from 1 to 254 do={/queue simple add name=(PC . $aaa) dst-address=(192.168.0. . $aaa) limit-at=500000/500000 max-limit=3000000/3000000}
 
 
/ ip firewall mangle
add chain=prerouting action=mark-packet new-packet-mark=all-mark \
passthrough=yes comment="" disabled=no
 
/ queue type
add name="PCQ-up" kind=pcq pcq-rate=1500000 pcq-limit=50 \
pcq-classifier=src-address pcq-total-limit=2000
add name="PCQ-down" kind=pcq pcq-rate=1500000 pcq-limit=50 \
pcq-classifier=dst-address pcq-total-limit=2000
 
/ queue simple
add name="PCQ" target-addresses=192.168.0.0/24 dst-address=0.0.0.0/0 \
interface=all parent=none packet-marks=all-mark direction=both priority=1 \
queue=PCQ-up/PCQ-down limit-at=0/0 max-limit=15000000/15000000 \
total-queue=default-small disabled=yes
/ system script
add name="PCQON" source=":if \(\[ /queue sim get \[/queue sim find \
name=\"PCQ\"\] disable \]=true \) do={/queue sim enable PCQ}" \
policy=ftp,reboot,read,write,policy,test,winbox,password
add name="PCQOFF" source=":if \(\[ /queue sim get \[/queue sim find \
name=\"PCQ\"\] disable \]=false \) do={/queue sim disable PCQ}" \
policy=ftp,reboot,read,write,policy,test,winbox,password
/ tool traffic-monitor
add name="PCQON" interface=WAN traffic=received trigger=above \
threshold=14800000 on-event=PCQON comment="" disabled=no
add name="PCQOFF" interface=WAN traffic=received trigger=below \
threshold=5000000 on-event=PCQOFF comment="" disabled=no
==================================================
上面是完整脚本,直接把每一段复制进去就可以了。需要修改的看下面的说明!
下面是注释
15M为例 静态是3M,达到14.8M后启用动态是1.5M!
:for aaa from 1 to 254 do={/queue simple add name=(PC . $aaa) dst-address=(192.168.0. . $aaa) limit-at=500000/500000 max-limit=3000000/3000000}
这个是建立静态限速,1to254 改为你内网的IP!比如 2 to 120!   192.168.0. 这里改为你的IP段!       limit-at=500000/500000   是平均网速500K,max-limit=3000000/3000000 是普通限速3M!
注意一下,,在网盟里,包括很多高手都把ROS的算法搞错了,在这里我抖正一下,ROS不是1KB=8Kbit!   而是 1000=1K   1000000=1M
/ ip firewall mangle
add chain=prerouting action=mark-packet new-packet-mark=all-mark \
passthrough=yes comment="" disabled=no
这个是固定脚本!
/ queue type
add name="PCQ-up" kind=pcq pcq-rate=1500000 pcq-limit=50 \
pcq-classifier=src-address pcq-total-limit=2000
add name="PCQ-down" kind=pcq pcq-rate=1500000 pcq-limit=50 \
pcq-classifier=dst-address pcq-total-limit=2000
这里把1500000改为你动态限速时的全网上传速度和下载速度!其他不要改!这里是1.5M!
/ queue simple
add name="PCQ" target-addresses=192.168.0.0/24 dst-address=0.0.0.0/0 \
interface=all parent=none packet-marks=all-mark direction=both priority=1 \
queue=PCQ-up/PCQ-down limit-at=0/0 max-limit=15000000/15000000 \
total-queue=default-small disabled=yes
到这里就是建立动态限速的策略了!192.168.0.0/24 改为你IP段!max-limit=15000000/15000000 这里是你总宽带,电信给你多少就填多少!其他不用改,,因为需要转跳到上面的!
/ system script
add name="PCQON" source=":if \(\[ /queue sim get \[/queue sim find \
name=\"PCQ\"\] disable \]=true \) do={/queue sim enable PCQ}" \
policy=ftp,reboot,read,write,policy,test,winbox,password
add name="PCQOFF" source=":if \(\[ /queue sim get \[/queue sim find \
name=\"PCQ\"\] disable \]=false \) do={/queue sim disable PCQ}" \
policy=ftp,reboot,read,write,policy,test,winbox,password
这个是启发脚本,就是启发动态和关闭动态的脚本!直接复制!
/ tool traffic-monitor
add name="PCQON" interface=WAN traffic=received trigger=above \
threshold=14800000 on-event=PCQON comment="" disabled=no
add name="PCQOFF" interface=WAN traffic=received trigger=below \
threshold=5000000 on-event=PCQOFF comment="" disabled=no
这个是流量监控,我有15M设置是14.8M启发,足够了。不会延时或者怎么的,不建议改得太少。threshold=5000000是少于5M时关闭动态!这个自己掌握好!多试试!
另外注意的是!interface=WAN   把WAN改成你外网的网卡!
上面的每一段都需要,少一段这个脚本就不完整!不然没效果不要说我!
关于时间段来启发脚本我发出来了,,只需要改最后一段就OK了!受之网盟,反哺网盟!
======================================================
/system scheduler add name=timeon interval=24h start-time=08:00:00 on-event={PCQON} disabled=no
/system scheduler add name=timeoff interval=24h start-time=23:59:59 on-event={PCQOFF} disabled=no
==============================================================
把最后一段替换成这段就是由时间段控制开关PCQ了!
以下是引用BA_a1073在2007-10-3 16:32:21的发言:
我到是想要个分时段限速的脚本,   比如8:00~14:00 是1个速度,   到了14:01开始切换第2套限速方案。
刚刚看了一下。然后再从网上查了点资料!
下面是一个ROS定时重启的例子!如果你认真看了我的帖子,应该可以结合我的方法来做出分开N个时段来定时开启关闭某个限速!
/system scheduler add name=reboot interval=24h start-time=06:59:00 on-event={/system reboot} disabled=no